POWERSHELL

MicrosoftTeams PowerShell Module 7.6.0 released

MicrosoftTeams PowerShell Module 7.6.0 released

Hi All,

A few days ago, Microsoft has released the MicrosoftTeams PowerShell Module 7.5.1-preview to the PowerShell Gallery.

Read more details in the Release Notes

  • Releases Get-CsAiAgents cmdlet.
  • Releases New-CsPhoneNumberBulkUpdateTagsOrder cmdlet.
  • Releases [Get|Set|Remove]-CsPhoneNumberTenantConfiguration cmdlets.
  • Releases [New|Get|Set|Remove]-CsAutoRecordingTemplate cmdlets.
  • Adds AutoRecordingTemplateId parameter to [New|Set]-CsCallQueue cmdlets.
  • Adds ResourceAccount parameter to [New|Set]-InboundBlockedNumberPattern cmdlets.
  • Adds CallerNumber parameter to the [Get|Test]-CsEffectiveTenantDialPlan cmdlets.
  • Adds LinksInTeams parameter to [Set|New]-CsTeamsMobilityPolicy cmdlets.
  • Adds ReportCall parameter to [Set|New]-CsTeamsCallingPolicy cmdlets.
  • Adds AllowMultipleScreenshare and PasscodeComplexity parameters to [Set|New]-CsTeamsMeetingPolicy cmdlets.
  • Adds Registration parameter to [Set|New]-CsTeamsEventsPolicy cmdlets.
  • Adds UserSettingsDefault parameter to [Set|New]-CsTeamsWorkLocationDetectionPolicy cmdlets.
  • Adds ResourceAccount parameter to Test-InboundBlockedNumberPattern cmdlet.
  • Adds AllowMultipleScreenshare parameter to Set-CsTeamsGuestMeetingConfiguration cmdlet.

WhiteboardAdmin 1.13.8 PowerShell Module released

WhiteboardAdmin 1.13.8 PowerShell Module released

Hi All,

A few days ago, Microsoft has released a new Version of the WhiteboardAdmin PowerShell Module to the PowerShell Gallery.

The Release Notes does not give a lot of insights

I am using the new PSResourceGet here instead of the PowerShellGet commands.

Show installed Versions and what’s available in PowerShell Gallery

Get-InstalledPSResource WhiteboardAdmin -Scope CurrentUser
Find-PSResource WhiteboardAdmin

Uninstalling the Modules with Uninstall-PSResource failed again.

Azure Log Analytics KQL Query with PowerShell

Azure Log Analytics KQL Query with PowerShell

Hi All,

You can run a Query in the Kusto Query Language (KQL) in Azure Log Analytics Workspace.

In my case i have configured Entra ID Diagnostic settings to store the SignInLogs to an Azure Log Analytics Workspace.

In this Article, i’ll explain how to Query a Log Analytics Workspace with PowerShell.

SigninLogs 
| where TimeGenerated > ago(30d)
| where ResultType == 0
| summarize count() by UserId, UserPrincipalName
| order by count_ desc

Azure VM Automatic Extension Upgrade

Azure VM Automatic Extension Upgrade

Hi All,

Recently i’ve been stumbled over this Article:

Azure Portal

Select the Machine > Settings > Extensions + Applications

Here you could “Enable automatic upgrade” of an Extension

AZ PowerShel

You need to use the AZ PowerShell Module

Connect to Azure

Connect-AzAccount -Tenant icewolfch.onmicrosoft.com

Sign In

Get Azure VM Extension

Get-AzVMExtension -ResourceGroupName "rg-exolab" -VMName DC01

Microsoft.Entra 1.2.0 PowerShell Modules have been released

Microsoft.Entra 1.2.0 PowerShell Modules have been released

Hi All,

A few hours ago, Microsoft has released new Microsoft.Entra and Microsoft.Entra.Beta PowerShell Modules.

The Entra PowerShell Module is similar to the Micrsoft.Graph PowerShell Modules. It has a “Master” Module with dependencies.

Same with the Microsoft.Entra.Beta Module. It has a “Master” Module with dependencies.

See the Release Notes

Check installed Versions and what’s available from the Powershell Gallery

Get-InstalledPSResource -Name Microsoft.Entra -Scope CurrentUser
Get-InstalledPSResource -Name Microsoft.Entra.Beta -Scope CurrentUser
Find-PSResource -Name Microsoft.Entra
Find-PSResource -Name Microsoft.Entra.Beta

Microsoft.PowerShell.PSResourceGet 1.2.0-rc1 released

Microsoft.PowerShell.PSResourceGet 1.2.0-rc1 released

Hi All,

Two days ago, Microsoft has released the Preview5 of the Microsoft.PowerShell.PSResourceGet PowerShell Module.

You can check the Release Notes

PowerShell 5

Check the Module Path

$Env:PSModulePath.Split(";")

I’ve simply deleted the Microsoft.PowerShell.PSResourceGet Folder in Windows Explorer - because there is no “Scope” Parameter in the Uninstall-Module command

Installing the PSResourceGet with Install-Module

Install-Module -Name Microsoft.PowerShell.PSResourceGet -Scope CurrentUser -AllowPrerelease
Get-InstalledPSResource -Name Microsoft.PowerShell.PSResourceGet -Scope CurrentUser

Azure PowerShell Module AZ 15.2.0 released

Azure PowerShell Module AZ 15.2.0 released

Hi All,

Just a few hours ago, a new Version of the AZ (Azure) PowerShell Module has been released to PowerShell Gallery.

I am using the new PSResourceGet here instead of the PowerShellGet commands.

Show installed Versions and what’s available in PowerShell Gallery

Get-InstalledPSResource -Name AZ -Scope CurrentUser
Find-PSResource -Name AZ

Uninstall the old Modules

Uninstall-PSResource AZ -Scope CurrentUser -SkipDependencyCheck
Uninstall-PSResource AZ.* -Scope CurrentUser -SkipDependencyCheck

Sharepoint Online PowerShell supports App Authentication with Certificate

Sharepoint Online PowerShell supports App Authentication with Certificate

Hi All,

With the MC1188595 in M365 Admin Center, Microsoft has announced the App-only Authentication with Certificate for the Microsoft.Online.SharePoint.PowerShell in the Version 16.0.26712.12000 or newer.

Entra Application

We need an Entra Application

In the “Certificate & Secrets” Section i upload a Certificate (*.cer File)

Certificate has been uploaded and configured

Now we need to add “API permission” and use “API’s my organization uses” and search for “Office 365 SharePoint Online”

New Microsoft Purview Roles in Entra

New Microsoft Purview Roles in Entra

Hi All,

Microsoft is rolling out three new Entra admin roles for Microsoft Purview to strengthen security when Purview interacts with Microsoft 365 services such as Exchange, SharePoint, OneDrive, and Teams.

New Entra Admin Roles:

  • Purview Workload Content Reader
  • Purview Workload Content Writer
  • Purview Workload Content Administrator

The key point of these new roles is that Microsoft explicitly notes an admin should not directly assign them to users. These roles are managed through Purview role assignments. Any manual assignment in Entra will be overwritten by Purview.

Microsoft MCP Server for Enterprise (Preview)

Microsoft MCP Server for Enterprise (Preview)

Hi All,

Over Christmas i’ve read about the “Microsoft MCP Server for Enterprise” that is currently in Preview

Setup

There is good Guidance on how to set it up here:

You will need to install the Microsoft.Entra.Beta PowerShell Module

Install-PSResource -Name Microsoft.Entra.Beta -Scope CurrentUser

Connect to Entra

Connect-Entra -Scopes 'Application.ReadWrite.All', 'Directory.Read.All', 'DelegatedPermissionGrant.ReadWrite.All'